GitHub Advisoryadvisory · PyPI

GHSA-2vpq-fh52-j3wv snowflake-connector-python vulnerable to SQL Injection in write_pandas

HIGH Published 2025-01-29 Modified 2025-04-09 Official page ↗
Aliases
CVE-2025-24793
Ecosystem
PyPI
Packages
snowflake-connector-python
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2025-01-29

Affected packages

• PyPI snowflake-connector-python: >= 2.2.5, < 3.13.1 → fixed in 3.13.1

Description

Issue Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandas_tools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1. Vulnerability Details A function from the snowflake.connector.pandas_tools module is not sanitizing all of its arguments, and queries using them are not parametrized. An attacker controlling these arguments could achieve SQL injection by passing crafted input. Any SQL executed that way by an attacker would still run in the context of the current session. Solution Snowflake released version 3.13.1 of the Snowflake Connector for Python, which fixes this issue. We recommend users upgrade to version 3.13.1. Additional Information If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne. For more information, please see our Vulnerability Disclosure Policy.

Related

Alias · CVE (1)

  • CVE-2025-24793 The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References