GitHub Advisoryadvisory · Packagist
GHSA-2wmj-8mqg-r9q8 Moodle has Incorrect Default Permissions
MEDIUM
Official page ↗
- Aliases
- CVE-2021-36397
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-276
- Reviewed
- 2023-03-08
Affected packages
• Packagist moodle/moodle: >= 3.11.0-beta, < 3.11.1 → fixed in 3.11.1
• Packagist moodle/moodle: >= 3.10.0-beta, < 3.10.5 → fixed in 3.10.5
• Packagist moodle/moodle: < 3.9.8 → fixed in 3.9.8
Description
In Moodle, insufficient capability checks meant message deletions were not limited to the current user.
Related
Alias · CVE (1)
- CVE-2021-36397 In Moodle, insufficient capability checks meant message deletions were not limited to the current user. vulnerability
Weakness · CWE (1)
- CWE-276 Incorrect Default Permissions weakness