GitHub Advisoryadvisory · Packagist
GHSA-2x2q-2xpv-mcf9 Magento 2 Community Edition SQLi Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-8127
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2023-07-18
Affected packages
• Packagist magento/community-edition: >= 2.2.0, < 2.2.10 → fixed in 2.2.10
• Packagist magento/community-edition: >= 2.3.0, < 2.3.2-p2 → fixed in 2.3.2-p2
Description
A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to an account with Newsletter Template editing permission could exfiltrate the Admin login data, and reset their password, effectively performing a privilege escalation.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
Related
Alias · CVE (1)
- CVE-2019-8127 A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-8127 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8127.yaml web
- https://github.com/magento/magento2 package
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update web
- https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update web