GitHub Advisoryadvisory · Packagist

GHSA-2x36-7xfm-pgm7 Moodle default permissions too permissive

MEDIUM Published 2022-04-23 Modified 2023-12-29 Official page ↗
Aliases
CVE-2012-1157
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-276
Reviewed
2023-12-29

Affected packages

• Packagist moodle/moodle: >= 2.2, < 2.2.2 → fixed in 2.2.2 • Packagist moodle/moodle: >= 2.1, < 2.1.5 → fixed in 2.1.5 • Packagist moodle/moodle: >= 2.0, < 2.0.8 → fixed in 2.0.8 • Packagist moodle/moodle: < 1.9.17 → fixed in 1.9.17

Description

Moodle before 2.2.2 default settings allowed all repositories to be viewable by all authenticated users.

Related

Alias · CVE (1)

  • CVE-2012-1157 Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default vulnerability

Weakness · CWE (1)

  • CWE-276 Incorrect Default Permissions weakness

References