GitHub Advisoryadvisory · npm
GHSA-2xcx-75h9-vr9h n8n's domain allowlist bypass enables credential exfiltration
MEDIUM
Official page ↗
- Aliases
- CVE-2026-25631
- Ecosystem
- npm
- Packages
- n8n
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N
- Weaknesses
- CWE-20, CWE-522
- Reviewed
- 2026-02-04
Affected packages
• npm n8n: < 1.121.0 → fixed in 1.121.0
Description
Impact
A vulnerability in the HTTP Request node's credential domain validation allowed an authenticated attacker to send requests with credentials to unintended domains, potentially leading to credential exfiltration.
This only might affect user who have credentials that use wildcard domain patterns (e.g., `*.example.com`) in the "Allowed domains" setting.
Patches
This issue is fixed in version 1.121.0 and later. All users are strongly encouraged to upgrade.
Workarounds
Until projects can upgrade:
• Replace wildcard domain patterns with explicit domain listings in HTTP Request credentials
• Review and restrict workflow creation/modification permissions to trusted users only
• Audit existing workflows using HTTP Request nodes with domain-restricted credentials
---
n8n has adopted CVSS 4.0 as primary score for all security advisories. CVSS 3.1 vector strings are provided for backward compatibility.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Related
Alias · CVE (1)
- CVE-2026-25631 n8n is an open source workflow automation platform. vulnerability