GitHub Advisoryadvisory · npm
GHSA-2xw5-3767-qxvm Malicious Package in ng-ui-library
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- ng-ui-library
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506
- Reviewed
- 2020-08-31
Affected packages
• npm ng-ui-library: >= 1.0.987, < 1.0.990 → fixed in 1.0.990
Description
Version 1.0.987 of `ng-ui-library` contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to `https://js-metrics.com/minjs.php?pl=`
Recommendation
Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.
Related
Weakness · CWE (1)
- CWE-506 Embedded Malicious Code weakness