GitHub Advisoryadvisory · PyPI
GHSA-2xxc-73fv-36f7 llama-index vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2023-39662
- Ecosystem
- PyPI
- Packages
- llama-index
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-94
- Reviewed
- 2023-08-15
Affected packages
• PyPI llama-index: < 0.9.14 → fixed in 0.9.14
Description
An issue in llama_index v.0.7.13 and before allows a remote attacker to execute arbitrary code via the `exec` parameter in PandasQueryEngine function.
Related
Alias · CVE (1)
- CVE-2023-39662 An issue in llama_index v.0.7.13 and before allows a remote attacker to execute arbitrary code via the `exec` parameter in… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-39662 advisory
- https://github.com/jerryjliu/llama_index/issues/7054 web
- https://github.com/run-llama/llama_index/commit/9f3e50a803f519af9ab62e63d413441c43001d81 web
- https://github.com/run-llama/llama_index/commit/aa6726706476e0f957a8d57a5ca89e519e93bad7 web
- https://github.com/jerryjliu/llama_index package
- https://github.com/pypa/advisory-database/tree/main/vulns/llama-index/PYSEC-2023-148.yaml web