GitHub Advisoryadvisory · Go
GHSA-322v-vh2g-qvpv Mattermost Fails to Restrict Certain Operations on System Admins
MEDIUM
Official page ↗
- Aliases
- CVE-2025-32093
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-863
- Reviewed
- 2025-04-14
Affected packages
• Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.2 → fixed in 10.5.2
• Go github.com/mattermost/mattermost-server: >= 10.4.0, < 10.4.4 → fixed in 10.4.4
• Go github.com/mattermost/mattermost-server: >= 9.11.0, < 9.11.10 → fixed in 9.11.10
• Go github.com/mattermost/mattermost/server/v8: >= 10.5.0, < 10.5.2 → fixed in 10.5.2
• Go github.com/mattermost/mattermost/server/v8: >= 10.4.0, < 10.4.4 → fixed in 10.4.4
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.10 → fixed in 9.11.10
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250227102013-aa4623a93199 → fixed in 8.0.0-20250227102013-aa4623a93199
Description
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to restrict certain operations on system admins to only other system admins, which allows delegated granular administration users with the "Edit Other Users" permission to perform unauthorized modifications to system administrators via improper permission validation.
Related
Alias · CVE (1)
- CVE-2025-32093 Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to restrict certain operations on system admins to only other… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness