GitHub Advisoryadvisory · Maven
GHSA-324h-2v7h-q3xx RCE vulnerability in Jenkins Yaml Axis Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2179
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:yaml-axis
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2022-12-16
Affected packages
• Maven org.jenkins-ci.plugins:yaml-axis: < 0.2.1 → fixed in 0.2.1
Description
Yaml Axis Plugin 0.2.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to configure a multi-configuration (Matrix) job, or control the contents of a previously configured job’s SCM repository.
Yaml Axis Plugin 0.2.1 configures its YAML parser to only instantiate safe types.
Related
Alias · CVE (1)
- CVE-2020-2179 Jenkins Yaml Axis Plugin 0.2.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2179 advisory
- https://github.com/jenkinsci/yaml-axis-plugin/commit/346802860c68a5a9bb4996c81fed4e05bee594f4 web
- https://github.com/jenkinsci/yaml-axis-plugin package
- https://jenkins.io/security/advisory/2020-04-16/#SECURITY-1825 web
- http://www.openwall.com/lists/oss-security/2020/04/16/4 web