GitHub Advisoryadvisory · Packagist

GHSA-32gr-x76g-267w SQL injection in webbuilders-group silverstripe-kapost-bridge

CRITICAL Published 2023-02-10 Modified 2023-02-16 Official page ↗
Aliases
CVE-2015-10077
Ecosystem
Packagist
Packages
webbuilders-group/silverstripe-kapost-bridge
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2023-02-16

Affected packages

• Packagist webbuilders-group/silverstripe-kapost-bridge: < 0.4.0 → fixed in 0.4.0

Description

A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The name of the patch is 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.

Related

Alias · CVE (1)

  • CVE-2015-10077 A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References