GitHub Advisoryadvisory · Packagist

GHSA-32hg-73hp-vwc8 Moodle allows attackers to modify "Exclude grade" settings

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2016-2155
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: >= 2.8.0, < 2.8.11 → fixed in 2.8.11 • Packagist moodle/moodle: >= 2.9.0, < 2.9.5 → fixed in 2.9.5 • Packagist moodle/moodle: >= 3.0.0, < 3.0.3 → fixed in 3.0.3

Description

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Related

Alias · CVE (1)

  • CVE-2016-2155 The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does… vulnerability

References