GitHub Advisoryadvisory · Packagist
GHSA-32jc-9p58-p82x Moodle Improper Access Control vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2023-23923
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2023-03-02
Affected packages
• Packagist moodle/moodle: < 3.9.19 → fixed in 3.9.19
• Packagist moodle/moodle: >= 3.10.0, < 3.11.12 → fixed in 3.11.12
• Packagist moodle/moodle: >= 4.0.0-beta, < 4.0.6 → fixed in 4.0.6
• Packagist moodle/moodle: >= 4.1.0-beta, < 4.1.1 → fixed in 4.1.1
Description
The vulnerability was found Moodle which exists due to insufficient limitations on the "start page" preference. A remote attacker can set that preference for another user. The vulnerability allows a remote attacker to gain unauthorized access to otherwise restricted functionality.
Related
Alias · CVE (1)
- CVE-2023-23923 The vulnerability was found Moodle which exists due to insufficient limitations on the "start page" preference. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness