GitHub Advisoryadvisory · PyPI

GHSA-32p4-gm2c-wmch ansible-core Incorrect Authorization vulnerability

MEDIUM Published 2024-11-06 Modified 2025-11-04 Official page ↗
Aliases
CVE-2024-9902
Ecosystem
PyPI
Packages
ansible-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:L
Weaknesses
CWE-863
Reviewed
2024-11-06

Affected packages

• PyPI ansible-core: < 2.14.18rc1 → fixed in 2.14.18rc1 • PyPI ansible-core: >= 2.15.0b1, < 2.15.13rc1 → fixed in 2.15.13rc1 • PyPI ansible-core: >= 2.16.0b1, < 2.16.13rc1 → fixed in 2.16.13rc1 • PyPI ansible-core: >= 2.17.0b1, < 2.17.6rc1 → fixed in 2.17.6rc1 • PyPI ansible-core: >= 2.18.0b1, < 2.18.0rc2 → fixed in 2.18.0rc2

Description

A flaw was found in Ansible. The ansible-core `user` module can allow an unprivileged user to silently create or replace the contents of any file on any system path and take ownership of it when a privileged user executes the `user` module against the unprivileged user's home directory. If the unprivileged user has traversal permissions on the directory containing the exploited target file, they retain full control over the contents of the file as its owner.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References