GitHub Advisoryadvisory · Go

GHSA-32q6-rr98-cjqv OpenFGA Authorization Bypass

MEDIUM Published 2025-01-13 Modified 2025-01-14 Official page ↗
Aliases
CVE-2024-56323
Ecosystem
Go
Packages
github.com/openfga/openfga
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
Weaknesses
CWE-285
Reviewed
2025-01-13

Affected packages

• Go github.com/openfga/openfga: >= 1.3.8, < 1.8.3 → fixed in 1.8.3

Description

Overview OpenFGA v1.3.8 to v1.8.2 (Helm chart openfga-0.1.38 to openfga-0.2.19, docker v1.3.8 to v.1.8.2) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Am I Affected? You are affected by this authorization bypass vulnerability if you are using OpenFGA v1.3.8 to v1.8.2, specifically under the following conditions: 1. Calling Check API or ListObjects with a model that uses conditions, and 2. OpenFGA is configured with caching enabled (`OPENFGA_CHECK_QUERY_CACHE_ENABLED`), and 3. Check API call or ListObjects API calls contain contextual tuples that include conditions. Fix Upgrade to v1.8.3. This upgrade is backwards compatible.

Related

Alias · CVE (1)

  • CVE-2024-56323 OpenFGA is an authorization/permission engine. vulnerability

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References