GitHub Advisoryadvisory · Go
GHSA-32rp-q37p-jg6w Insecure plugin handling in Mattermost
HIGH
Official page ↗
- Aliases
- CVE-2022-1384
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server/v6
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-862
- Reviewed
- 2022-04-28
Affected packages
• Go github.com/mattermost/mattermost-server/v6: >= 6.4.0, < 6.5.0 → fixed in 6.5.0
Description
Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which allows an authenticated and an authorized user to install and exploit an old plugin version from the Marketplace which might have known vulnerabilities.
Related
Alias · CVE (1)
- CVE-2022-1384 Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which… vulnerability
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness