GitHub Advisoryadvisory · Packagist
GHSA-3327-jr93-7hq3 Drupal access bypass vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-6930
- Ecosystem
- Packagist
- Packages
- drupal/core, drupal/drupal
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284
- Reviewed
- 2024-04-23
Affected packages
• Packagist drupal/core: >= 8.4.0, < 8.4.5 → fixed in 8.4.5
• Packagist drupal/drupal: >= 8.4.0, < 8.4.5 → fixed in 8.4.5
Description
In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated version of a node as the default fallback for access queries. This fallback is used for languages that do not yet have a translated version of the created node. This can result in an access bypass vulnerability. This issue is mitigated by the fact that it only applies to sites that a) use the Content Translation module; and b) use a node access module such as Domain Access which implement hook_node_access_records().
Related
Alias · CVE (1)
- CVE-2017-6930 In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6930 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6930.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6930.yaml web
- https://github.com/drupal/core package
- https://www.drupal.org/sa-core-2018-001 web