GitHub Advisoryadvisory · Maven

GHSA-3357-829x-m9pr Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks

HIGH Published 2018-10-18 Modified 2022-09-13 Official page ↗
Aliases
CVE-2015-5175
Ecosystem
Maven
Packages
org.apache.cxf.fediz:fediz-idp, org.apache.cxf.fediz:fediz-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• Maven org.apache.cxf.fediz:fediz-idp: < 1.1.3 → fixed in 1.1.3 • Maven org.apache.cxf.fediz:fediz-idp: >= 1.2, < 1.2.1 → fixed in 1.2.1 • Maven org.apache.cxf.fediz:fediz-core: < 1.1.3 → fixed in 1.1.3 • Maven org.apache.cxf.fediz:fediz-core: >= 1.2, < 1.2.1 → fixed in 1.2.1

Description

Application plugins in Apache CXF Fediz prior to version 1.1.3 and 1.2.x prior to 1.2.1 allow remote attackers to create a denial of service.

Related

Alias · CVE (1)

  • CVE-2015-5175 Application plugins in Apache CXF Fediz before 1.1.3 and 1.2.x before 1.2.1 allow remote attackers to cause a denial of service. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References