GitHub Advisoryadvisory · Packagist

GHSA-33cj-w75f-49m2 Magento 2 Community Edition Server-Side Request Forgery vulnerability

HIGH Published 2022-05-24 Modified 2024-02-12 Official page ↗
Aliases
CVE-2019-7911
Ecosystem
Packagist
Packages
magento/community-edition
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-918
Reviewed
2023-08-01

Affected packages

• Packagist magento/community-edition: >= 2.1.0, < 2.1.18 → fixed in 2.1.18 • Packagist magento/community-edition: >= 2.2.0, < 2.2.9 → fixed in 2.2.9 • Packagist magento/community-edition: >= 2.3.0, < 2.3.2 → fixed in 2.3.2

Description

A server-side request forgery (SSRF) vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This can be exploited by an authenticated user with access to the admin panel to manipulate system configuration and execute arbitrary code.

Related

Alias · CVE (1)

  • CVE-2019-7911 A server-side request forgery (SSRF) vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2,… vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References