GitHub Advisoryadvisory · npm

GHSA-33qr-m49q-rxfx Compromised xrpl.js versions 4.2.1, 4.2.2, 4.2.3, 4.2.4, and 2.14.2

CRITICAL Published 2025-04-22 Modified 2025-04-22 Official page ↗
Aliases
CVE-2025-32965
Ecosystem
npm
Packages
xrpl
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-506
Reviewed
2025-04-22

Affected packages

• npm xrpl: >= 4.2.1, < 4.2.5 → fixed in 4.2.5 • npm xrpl: >= 2.14.2, < 2.14.3 → fixed in 2.14.3

Description

Impact Versions 4.2.1, 4.2.2, 4.2.3, and 4.2.4 of xrpl.js were compromised and contained malicious code designed to exfiltrate private keys. If you are using one of these versions, stop immediately and rotate any private keys or secrets used with affected systems. Version 2.14.2 is also malicious, though it is less likely to lead to exploitation as it is not compatible with other 2.x versions. Patches Upgrade to version 4.2.5 or 2.14.3. Required Actions To secure funds, think carefully about whether any keys may have been compromised by this supply chain attack, and mitigate by sending funds to secure wallets, and/or rotating keys: The XRP Ledger supports key rotation: https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/assign-a-regular-key-pair If any account's master key is potentially compromised, you should disable it: https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/disable-master-key-pair References https://www.aikido.dev/blog/xrp-supplychain-attack-official-npm-package-infected-with-crypto-stealing-backdoor

Related

Alias · CVE (1)

  • CVE-2025-32965 xrpl.js is a JavaScript/TypeScript API for interacting with the XRP Ledger in Node.js and the browser. vulnerability

Weakness · CWE (1)

  • CWE-506 Embedded Malicious Code weakness

References