GitHub Advisoryadvisory · Go
GHSA-3439-vqgj-2gcf Mattermost allows attackers to manipulate administrator terminals via crafted messages containing ANSI and OSC escape sequences
HIGH
Official page ↗
- Aliases
- CVE-2026-3108
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-150
- Reviewed
- 2026-03-31
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 11.4.0-rc1, < 11.4.1 → fixed in 11.4.1
• Go github.com/mattermost/mattermost/server/v8: >= 11.3.0-rc1, < 11.3.2 → fixed in 11.3.2
• Go github.com/mattermost/mattermost/server/v8: >= 11.2.0-rc1, < 11.2.3 → fixed in 11.2.3
• Go github.com/mattermost/mattermost/server/v8: >= 10.11.0-rc1, < 10.11.11 → fixed in 10.11.11
• Go github.com/mattermost/mattermost/server/v8: >= 8.0.0-20260105080200-d27a2195068d, < 8.0.0-20260217110922-b7d4a1f1f59b → fixed in 8.0.0-20260217110922-b7d4a1f1f59b
Description
Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to sanitize user-controlled post content in the mmctl commands terminal output which allows attackers to manipulate administrator terminals via crafted messages containing ANSI and OSC escape sequences that enable screen manipulation, fake prompts, and clipboard hijacking. Mattermost Advisory ID: MMSA-2026-00599.
Related
Alias · CVE (1)
- CVE-2026-3108 Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to sanitize user-controlled post content… vulnerability
Weakness · CWE (1)
- CWE-150 Improper Neutralization of Escape, Meta, or Control Sequences weakness