GitHub Advisoryadvisory · Go

GHSA-34p5-jp77-fcrc Command injection in Rancher Git package

MEDIUM Published 2023-01-25 Modified 2023-02-15 Official page ↗
Aliases
CVE-2022-43758
Ecosystem
Go
Packages
github.com/rancher/rancher
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-77, CWE-78, CWE-88
Reviewed
2023-01-25

Affected packages

• Go github.com/rancher/rancher: >= 2.5.0, < 2.5.17 → fixed in 2.5.17 • Go github.com/rancher/rancher: >= 2.6.0, < 2.6.10 → fixed in 2.6.10 • Go github.com/rancher/rancher: >= 2.7.0, < 2.7.1 → fixed in 2.7.1

Description

Impact An issue was discovered in Rancher from versions 2.5.0 up to and including 2.5.16, 2.6.0 up to and including 2.6.9 and 2.7.0, where a command injection vulnerability is present in the Rancher Git package. This package uses the underlying Git binary available in the Rancher container image to execute Git operations. Specially crafted commands, when not properly disambiguated, can cause confusion when executed through Git, resulting in command injection in the underlying Rancher host. This issue can potentially be exploited in Rancher in two ways: 1. Adding an untrusted Helm catalog, in the Catalogs menu, that contains maliciously designed repo URL configuration in Helm charts. 2. Modifying the URL configuration used to download KDM (Kontainer Driver Metadata) releases. By default, only the Rancher admin has permission to manage both configurations for the local cluster (the cluster where Rancher is provisioned). Note: More information about this category of issue in version control system (VCS) tools are available in Snyk's blog post. Workarounds Except for only adding trusted catalogs and the KDM URL to Rancher, there is no other workaround besides updating Rancher to a patched version. Patches Patched versions include releases 2.5.17, 2.6.10, 2.7.1 and later versions. It is also important to update to a patched version in case Rancher or its standalone Git package implementation is used as a Go library instead of the application itself. Otherwise, this vulnerability might affect your dependent code. For more information If you have any questions or comments about this advisory: • Reach out to SUSE Rancher Security team for security related inquiries. • Open an issue in Rancher repository. • Verify our support matrix and product support lifecycle.

Related

Alias · CVE (1)

  • CVE-2022-43758 A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in SUSE Rancher allows code… vulnerability

Weakness · CWE (3)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
  • CWE-88 Improper Neutralization of Argument Delimiters in a Command weakness

References