GitHub Advisoryadvisory · Maven

GHSA-34q3-p352-c7q8 Central Dogma Authentication Bypass Vulnerability via Session Leakage

CRITICAL Published 2024-02-02 Modified 2024-04-25 Official page ↗
Aliases
CVE-2024-1143
Ecosystem
Maven
Packages
com.linecorp.centraldogma:centraldogma-server
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Reviewed
2024-02-02

Affected packages

• Maven com.linecorp.centraldogma:centraldogma-server: < 0.64.1 → fixed in 0.64.1

Description

Vulnerability Overview A vulnerability has been identified in Central Dogma versions prior to 0.64.1, allowing for the leakage of user sessions and subsequent authentication bypass. The issue stems from a Cross-Site Scripting (XSS) attack vector that targets the RelayState of Security Assertion Markup Language (SAML). Impact Successful exploitation of this vulnerability enables malicious actors to leak user sessions, leading to the compromise of authentication mechanisms. This, in turn, can facilitate unauthorized access to sensitive resources. Patches This vulnerability is addressed and resolved in Central Dogma version 0.64.1 Users are strongly encouraged to upgrade to this version or later to mitigate the risk associated with the authentication bypass. Workarounds No viable workarounds are currently available for this vulnerability. It is recommended to apply the provided patch promptly. References • OASIS SAML v2.0 Errata 05 • OWASP XSS Prevention Cheat Sheet

Related

Alias · CVE (1)

  • CVE-2024-1143 Central Dogma versions prior to 0.64.1 is vulnerable to Cross-Site Scripting (XSS), which could allow for the leakage of user sessions and… vulnerability

References