GitHub Advisoryadvisory · PyPI
GHSA-34wm-4hw7-qfjv Feast vulnerable to Deserialization of Untrusted Data
HIGH
Official page ↗
- Aliases
- CVE-2025-11157
- Ecosystem
- PyPI
- Packages
- feast
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2026-01-02
Affected packages
• PyPI feast: < 0.54.0 → fixed in 0.54.0
Description
A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer job located at `feast/sdk/python/feast/infra/compute_engines/kubernetes/main.py`. The vulnerability arises from the use of `yaml.load(..., Loader=yaml.Loader)` to deserialize `/var/feast/feature_store.yaml` and `/var/feast/materialization_config.yaml`. This method allows for the instantiation of arbitrary Python objects, enabling an attacker with the ability to modify these YAML files to execute OS commands on the worker pod. This vulnerability can be exploited before the configuration is validated, potentially leading to cluster takeover, data poisoning, and supply-chain sabotage.
Related
Alias · CVE (1)
- CVE-2025-11157 A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness