GitHub Advisoryadvisory · Maven
GHSA-353m-jh2m-72v4 Code injection in stanford-parser
CRITICAL
Official page ↗
- Aliases
- CVE-2023-39020
- Ecosystem
- Maven
- Packages
- edu.stanford.nlp:stanford-parser
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2023-07-28
Affected packages
• Maven edu.stanford.nlp:stanford-parser: < 4.5.5 → fixed in 4.5.5
Description
stanford-parser v3.9.2 and below was discovered to contain a code injection vulnerability in the component edu.stanford.nlp.io.getBZip2PipedInputStream. This vulnerability is exploited via passing an unchecked argument.
Related
Alias · CVE (1)
- CVE-2023-39020 stanford-parser v3.9.2 and below was discovered to contain a code injection vulnerability in the component… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness