GitHub Advisoryadvisory · Packagist

GHSA-35c5-28pg-2qg4 Symfony Authentication Bypass

CRITICAL Published 2022-05-14 Modified 2024-04-25 Official page ↗
Aliases
CVE-2018-11407
Ecosystem
Packagist
Packages
symfony/security-core, symfony/security, symfony/symfony
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287
Reviewed
2024-04-25

Affected packages

• Packagist symfony/security-core: >= 2.8.0, < 2.8.37 → fixed in 2.8.37 • Packagist symfony/security-core: >= 3.0.0, < 3.3.17 → fixed in 3.3.17 • Packagist symfony/security-core: >= 3.4.0, < 3.4.7 → fixed in 3.4.7 • Packagist symfony/security-core: >= 4.0.0, < 4.0.7 → fixed in 4.0.7 • Packagist symfony/security: >= 2.8.0, < 2.8.37 → fixed in 2.8.37 • Packagist symfony/security: >= 3.0.0, < 3.3.17 → fixed in 3.3.17 • Packagist symfony/security: >= 3.4.0, < 3.4.7 → fixed in 3.4.7 • Packagist symfony/security: >= 4.0.0, < 4.0.7 → fixed in 4.0.7 • Packagist symfony/symfony: >= 2.8.0, < 2.8.37 → fixed in 2.8.37 • Packagist symfony/symfony: >= 3.0.0, < 3.3.17 → fixed in 3.3.17 • Packagist symfony/symfony: >= 3.4.0, < 3.4.7 → fixed in 3.4.7 • Packagist symfony/symfony: >= 4.0.0, < 4.0.7 → fixed in 4.0.7

Description

An issue was discovered in the LDAP component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.7. It allows remote attackers to bypass authentication by logging in with a "null" password and valid username, which triggers an unauthenticated bind. NOTE: this issue exists because of an incomplete fix for CVE-2016-2403.

Related

Alias · CVE (1)

  • CVE-2018-11407 An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References