GitHub Advisoryadvisory · npm, RubyGems

GHSA-35jh-r3h4-6jhm Command Injection in lodash

HIGH Published 2021-05-06 Modified 2025-08-12 Official page ↗
Aliases
CVE-2021-23337
Ecosystem
npm, RubyGems
Packages
lodash, lodash-es, lodash.template, lodash-template, lodash-rails
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77, CWE-94
Reviewed
2021-03-31

Affected packages

• npm lodash: < 4.17.21 → fixed in 4.17.21 • npm lodash-es: < 4.17.21 → fixed in 4.17.21 • npm lodash.template: <= 4.5.0 (no fix yet) • npm lodash-template: <= 1.0.0 (no fix yet) • RubyGems lodash-rails: < 4.17.21 → fixed in 4.17.21

Description

`lodash` versions prior to 4.17.21 are vulnerable to Command Injection via the template function.

Related

Alias · CVE (1)

  • CVE-2021-23337 Lodash versions prior to 4.17.21 are vulnerable to Command Injection via the template function. vulnerability

Weakness · CWE (2)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-94 Improper Control of Generation of Code weakness

References