GitHub Advisoryadvisory · Packagist

GHSA-35pf-37c6-jxjv PrestaShop has multiple stored XSS vulnerabilities via unprotected Template variables

HIGH Published 2026-03-25 Modified 2026-03-27 Official page ↗
Aliases
CVE-2026-33673
Ecosystem
Packagist
Packages
prestashop/prestashop
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2026-03-25

Affected packages

• Packagist prestashop/prestashop: >= 9.0.0-alpha.1, < 9.1.0 → fixed in 9.1.0 • Packagist prestashop/prestashop: < 8.2.5 → fixed in 8.2.5

Description

Impact Multiple stored Cross-Site Scripting (stored XSS) vulnerabilities in the BO: an attacker who can inject data into the database, via limited back-office access or a previously existing vulnerability, can exploit unprotected variables in back-office templates. Patches Patched on 8.2.5 and 9.1.0 Workarounds None References None

Related

Alias · CVE (1)

  • CVE-2026-33673 PrestaShop is an open source e-commerce web application. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References