GitHub Advisoryadvisory · Packagist

GHSA-36cm-vrqh-8p98 Moodle allows attackers to cause a denial of service

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-2268
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.9 → fixed in 2.6.9 • Packagist moodle/moodle: >= 2.7.0, < 2.7.6 → fixed in 2.7.6 • Packagist moodle/moodle: >= 2.8.0, < 2.8.4 → fixed in 2.8.4

Description

filter/urltolink/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.

Related

Alias · CVE (1)

  • CVE-2015-2268 filter/urltolink/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote… vulnerability

References