GitHub Advisoryadvisory · Packagist
GHSA-36vv-q5jv-94cj Drupal Google Tag Cross-Site Scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-31682
- Ecosystem
- Packagist
- Packages
- drupal/google_tag
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-02
Affected packages
• Packagist drupal/google_tag: < 1.8.0 → fixed in 1.8.0
• Packagist drupal/google_tag: >= 2.0.0, < 2.0.8 → fixed in 2.0.8
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS). This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.
Related
Alias · CVE (1)
- CVE-2025-31682 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness