GitHub Advisoryadvisory · Maven
GHSA-373r-9mg8-3jc4 Apache Geode vulnerable to Cross-Site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2022-34870
- Ecosystem
- Maven
- Packages
- org.apache.geode:geode-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-10-25
Affected packages
• Maven org.apache.geode:geode-core: < 1.15.1 → fixed in 1.15.1
Description
Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to view Region entries.
Related
Alias · CVE (1)
- CVE-2022-34870 Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness