GitHub Advisoryadvisory · Packagist
GHSA-374w-gwqr-fmxg brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS
MEDIUM
Official page ↗
- Aliases
- CVE-2022-33154
- Ecosystem
- Packagist
- Packages
- brotkrueml/schema
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-17
Affected packages
• Packagist brotkrueml/schema: >= 2.0.0, < 2.5.1 → fixed in 2.5.1
• Packagist brotkrueml/schema: < 1.13.1 → fixed in 1.13.1
Description
The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Related
Alias · CVE (1)
- CVE-2022-33154 The schema (aka Embedding schema.org vocabulary) extension before 1.13.1 and 2.x before 2.5.1 for TYPO3 allows XSS. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness