GitHub Advisoryadvisory · npm

GHSA-376v-xgjx-7mfr fastify-bearer-auth vulnerable to Timing Attack Vector

HIGH Published 2022-07-15 Modified 2022-07-21 Official page ↗
Aliases
CVE-2022-31142
Ecosystem
npm
Packages
fastify-bearer-auth, @fastify/bearer-auth
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-203, CWE-208
Reviewed
2022-07-15

Affected packages

• npm fastify-bearer-auth: >= 5.0.1, <= 6.0.3 (no fix yet) • npm @fastify/bearer-auth: < 7.0.2 → fixed in 7.0.2 • npm @fastify/bearer-auth: >= 8.0.0, < 8.0.1 → fixed in 8.0.1

Description

Impact fastify-bearer-auth does not securely use crypto.timingSafeEqual. A malicious attacker could estimate the length of one valid bearer token. According to the corresponding RFC 6750, the bearer token has only base64 valid characters, reducing the range of characters for a brute force attack. All versions of fastify-bearer-auth are also affected. Patches We released: • v8.0.1 with a fix for the Fastify v4 line • v7.0.2 with a fix for the Fastify v3 line Workarounds There are no workarounds. Update your dependencies. References https://hackerone.com/reports/1633287 For more information If you have any questions or comments about this advisory: • Open an issue in https://github.com/fastify/fastify-bearer-auth • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2022-31142 @fastify/bearer-auth is a Fastify plugin to require bearer Authorization headers. vulnerability

Weakness · CWE (2)

  • CWE-203 Observable Discrepancy weakness
  • CWE-208 Observable Timing Discrepancy weakness

References