GitHub Advisoryadvisory · npm
GHSA-377f-vvrc-9wgg Malicious Package in zemen
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- zemen
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506
- Reviewed
- 2020-08-31
Affected packages
• npm zemen: >= 0.0.5, < 0.0.6 → fixed in 0.0.6
Description
Version 0.0.5 of `zemen` contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to `https://js-metrics.com/minjs.php?pl=`
Recommendation
Remove the package from your environment. It's also recommended to evaluate your application to determine whether or not user data was compromised.
Related
Weakness · CWE (1)
- CWE-506 Embedded Malicious Code weakness