GitHub Advisoryadvisory · Maven

GHSA-37pw-qw47-4jxm Privilege escalation vulnerability in Apache Hadoop

HIGH Published 2019-05-31 Modified 2021-05-11 Official page ↗
Aliases
CVE-2018-8029
Ecosystem
Maven
Packages
org.apache.hadoop:hadoop-main
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-285
Reviewed
2019-05-31

Affected packages

• Maven org.apache.hadoop:hadoop-main: >= 2.2.0, < 2.8.4 → fixed in 2.8.4 • Maven org.apache.hadoop:hadoop-main: >= 2.9.0, < 2.9.2 → fixed in 2.9.2 • Maven org.apache.hadoop:hadoop-main: >= 3.0.0, < 3.1.1 → fixed in 3.1.1

Description

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Related

Alias · CVE (1)

  • CVE-2018-8029 In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run… vulnerability

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References