GitHub Advisoryadvisory · Packagist

GHSA-382v-gxj9-ffhc Moodle uses predictable password-recovery tokens

HIGH Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-5267
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.7.10 → fixed in 2.7.10 • Packagist moodle/moodle: >= 2.8.0, < 2.8.8 → fixed in 2.8.8 • Packagist moodle/moodle: >= 2.9.0, < 2.9.2 → fixed in 2.9.2

Description

lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 relies on the PHP mt_rand function to implement the random_string and complex_random_string functions, which makes it easier for remote attackers to predict password-recovery tokens via a brute-force approach.

Related

Alias · CVE (1)

  • CVE-2015-5267 lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 relies on the PHP mt_rand… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References