GitHub Advisoryadvisory · Packagist
GHSA-389c-cf87-qmwj Cross-site Scripting in livewire/livewire
MEDIUM
Official page ↗
- Aliases
- CVE-2024-21504
- Ecosystem
- Packagist
- Packages
- livewire/livewire
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-03-20
Affected packages
• Packagist livewire/livewire: >= 3.3.5, < 3.4.9 → fixed in 3.4.9
Description
Versions of the package livewire/livewire from 3.3.5 and before 3.4.9 are vulnerable to Cross-site Scripting (XSS) when a page uses [Url] for a property. An attacker can inject HTML code in the context of the user's browser session by crafting a malicious link and convincing the user to click on it.
Related
Alias · CVE (1)
- CVE-2024-21504 Versions of the package livewire/livewire from 3.3.5 and before 3.4.9 are vulnerable to Cross-site Scripting (XSS) when a page uses [Url]… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-21504 advisory
- https://github.com/livewire/livewire/pull/8117 web
- https://github.com/livewire/livewire/commit/c65b3f0798ab2c9338213ede3588c3cdf4e6fcc0 web
- https://github.com/livewire/livewire package
- https://github.com/livewire/livewire/releases/tag/v3.4.9 web
- https://security.snyk.io/vuln/SNYK-PHP-LIVEWIRELIVEWIRE-6446222 web