GitHub Advisoryadvisory · PyPI

GHSA-38rv-5jqc-m2cv Recurly vulnerable to SSRF

CRITICAL Published 2019-01-04 Modified 2024-10-26 Official page ↗
Aliases
CVE-2017-0906
Ecosystem
PyPI
Packages
recurly
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-918
Reviewed
2020-06-16

Affected packages

• PyPI recurly: >= 2.6.0, < 2.6.2 → fixed in 2.6.2 • PyPI recurly: >= 2.5.0, < 2.5.1 → fixed in 2.5.1 • PyPI recurly: >= 2.4.0, < 2.4.5 → fixed in 2.4.5 • PyPI recurly: >= 2.3.0, < 2.3.1 → fixed in 2.3.1 • PyPI recurly: >= 2.2.0, < 2.2.22 → fixed in 2.2.22 • PyPI recurly: >= 2.1.0, < 2.1.16 → fixed in 2.1.16 • PyPI recurly: < 2.0.5 → fixed in 2.0.5

Description

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the `Resource.get` method that could result in compromise of API keys or other critical resources.

Related

Alias · CVE (1)

  • CVE-2017-0906 The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery… vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References