GitHub Advisoryadvisory · npm
GHSA-3949-f494-cm99 Cross-site Scripting in Prism
HIGH
Official page ↗
- Aliases
- CVE-2022-23647
- Ecosystem
- npm
- Packages
- prismjs
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2022-02-22
Affected packages
• npm prismjs: >= 1.14.0, < 1.27.0 → fixed in 1.27.0
Description
Impact
Prism's Command line plugin can be used by attackers to achieve an XSS attack. The Command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code.
Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted.
Patches
This bug has been fixed in v1.27.0.
Workarounds
Do not use the Command line plugin on untrusted inputs, or sanitized all code blocks (remove all HTML code text) from all code blocks that use the Command line plugin.
References
• https://github.com/PrismJS/prism/pull/3341
Related
Alias · CVE (1)
- CVE-2022-23647 Prism is a syntax highlighting library. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/PrismJS/prism/security/advisories/GHSA-3949-f494-cm99 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-23647 advisory
- https://github.com/PrismJS/prism/pull/3341 web
- https://github.com/PrismJS/prism/commit/e002e78c343154e1c0ddf9d6a0bb85689e1a5c7c web
- https://github.com/PrismJS/prism package