GitHub Advisoryadvisory · Packagist
GHSA-39ch-rg26-gmq5 Magento DOM-based Cross-Site Scripting vulnerability on mage-messages cookies
MEDIUM
Official page ↗
- Aliases
- CVE-2021-28556
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-01-11
Affected packages
• Packagist magento/community-edition: >= 2.4.0, < 2.4.2-p1 → fixed in 2.4.2-p1
• Packagist magento/community-edition: < 2.3.7 → fixed in 2.3.7
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.
Related
Alias · CVE (1)
- CVE-2021-28556 Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness