GitHub Advisoryadvisory · Packagist
GHSA-39g6-x4x8-5jcm Drupal Core Potential Cross-Site Scripting (XSS) via Error Messages
MEDIUM
Official page ↗
- Aliases
- CVE-2025-3057
- Ecosystem
- Packagist
- Packages
- drupal/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-02
Affected packages
• Packagist drupal/core: >= 8.0.0, < 10.3.13 → fixed in 10.3.13
• Packagist drupal/core: >= 10.4.0, < 10.4.3 → fixed in 10.4.3
• Packagist drupal/core: >= 11.0.0, < 11.0.12 → fixed in 11.0.12
• Packagist drupal/core: >= 11.1.0, < 11.1.3 → fixed in 11.1.3
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.
Related
Alias · CVE (1)
- CVE-2025-3057 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness