GitHub Advisoryadvisory · Packagist

GHSA-39wj-j3jc-858m XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic

CRITICAL Published 2021-01-19 Modified 2021-01-19 Official page ↗
Aliases
CVE-2020-35124
Ecosystem
Packagist
Packages
mautic/core
Severity
Critical
Weaknesses
CWE-79
Reviewed
2021-01-19

Affected packages

• Packagist mautic/core: >= 3.0.0, < 3.2.4 → fixed in 3.2.4 • Packagist mautic/core: >= 2.0.0, < 2.16.5 → fixed in 2.16.5

Description

Impact This is a cross-site scripting vulnerability which affects every version of Mautic and could allow an attacker unauthorised administrator level access to Mautic. This vulnerability was reported by Naveen Sunkavally at Horizon3.ai. Patches Upgrade to 3.2.4 or 2.16.5. Link to patch for 2.x versions: https://github.com/mautic/mautic/compare/2.16.4...2.16.5.diff Link to patch for 3.x versions: https://github.com/mautic/mautic/compare/3.2.2...3.2.4.diff Workarounds None For more information If you have any questions or comments about this advisory: • Post in https://forum.mautic.org/c/support • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2020-35124 A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4 allows remote attackers to inject executable… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References