GitHub Advisoryadvisory · PyPI
GHSA-3c67-gc48-983w Path Traversal in Ansible
MEDIUM
Official page ↗
- Aliases
- CVE-2020-10691
- Ecosystem
- PyPI
- Packages
- ansible
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L
- Weaknesses
- CWE-22
- Reviewed
- 2021-04-05
Affected packages
• PyPI ansible: >= 2.9.0a1, < 2.9.7 → fixed in 2.9.7
Description
An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running `ansible-galaxy collection` install. When extracting a collection .tar.gz file, the directory is created without sanitizing the filename. An attacker could take advantage to overwrite any file within the system.
Related
Alias · CVE (1)
- CVE-2020-10691 An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install. vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-10691 advisory
- https://github.com/ansible/ansible/pull/68596 web
- https://github.com/ansible/ansible/commit/b2551bb6943eec078066aa3a923e0bb3ed85abe8 web
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10691 web
- https://github.com/advisories/GHSA-3c67-gc48-983w advisory
- https://github.com/ansible/ansible package
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-2.yaml web