GitHub Advisoryadvisory · npm
GHSA-3cqr-58rm-57f8 Arbitrary Code Execution in Handlebars
HIGH
Official page ↗
- Aliases
- CVE-2019-20920
- Ecosystem
- npm
- Packages
- handlebars
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L
- Weaknesses
- CWE-94
- Reviewed
- 2021-04-22
Affected packages
• npm handlebars: < 3.0.8 → fixed in 3.0.8
• npm handlebars: >= 4.0.0, < 4.5.3 → fixed in 4.5.3
Description
Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).
Related
Alias · CVE (1)
- CVE-2019-20920 Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-20920 advisory
- https://github.com/handlebars-lang/handlebars.js/commit/156061eb7707575293613d7fdf90e2bdaac029ee web
- https://github.com/handlebars-lang/handlebars.js/commit/d54137810a49939fd2ad01a91a34e182ece4528e web
- https://snyk.io/vuln/SNYK-JS-HANDLEBARS-534478 web
- https://www.npmjs.com/advisories/1316 web
- https://www.npmjs.com/advisories/1324 web
- https://www.npmjs.com/package/handlebars web