GitHub Advisoryadvisory · npm
GHSA-3crj-w4f5-gwh4 Processing untrusted theming resources might execute arbitrary code (ACE)
HIGH
Official page ↗
- Aliases
- CVE-2021-21316
- Ecosystem
- npm
- Packages
- less-openui5
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
- Weaknesses
- CWE-74
- Reviewed
- 2021-01-29
Affected packages
• npm less-openui5: < 0.10.0 → fixed in 0.10.0
Description
Impact
When processing theming resources (i.e. `*.less` files) with less-openui5 that originate from an untrusted source, those resources might contain JavaScript code which will be executed in the context of the build process.
While this is a feature of the Less.js library, it is an unexpected behavior in the context of OpenUI5 and SAPUI5 development.
Especially in the context of UI5 Tooling, which relies on less-openui5, this poses a security threat:
An attacker might create a library or theme-library containing a custom control or theme, hiding malicious JavaScript code in one of the `.less` files.
This is an example of inline JavaScript in a Less file:
```less
.rule {
@var: `(function(){console.log('Hello from JavaScript'); process.exit(1);})()`;
color: @var;
}
```
Starting with Less.js version 3.0.0, the Inline JavaScript feature is disabled by default. less-openui5 however currently uses a fork of Less.js v1.6.3.
Note that disabling the Inline JavaScript feature in Less.js versions 1.x, still evaluates code has additional double codes around it:
```less
.rule {
@var: "`(function(){console.log('Hello from JavaScript'); process.exit(1);})()`";
color: @var;
}
```
Patches
We decided to remove the inline JavaScript evaluation feature completely from the code of our Less.js fork.
This fix is available in less-openui5 version v0.10.0
Workarounds
Only process trusted theming resources.
For more information
If you have any questions or comments about this advisory:
• Open an issue in https://github.com/SAP/less-openui5
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2021-21316 less-openui5 is an npm package which enables building OpenUI5 themes with Less.js. vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://github.com/SAP/less-openui5/security/advisories/GHSA-3crj-w4f5-gwh4 web
- https://nvd.nist.gov/vuln/detail/CVE-2021-21316 advisory
- https://github.com/SAP/less-openui5/commit/c0d3a8572974a20ea6cee42da11c614a54f100e8 web
- https://github.com/SAP/less-openui5/releases/tag/v0.10.0 web
- https://www.npmjs.com/package/less-openui5 web
- http://lesscss.org/usage/#less-options-enable-inline-javascript-deprecated- web