GitHub Advisoryadvisory · PyPI

GHSA-3cv6-jpf6-8222 LiteLLM: Authenticated SSRF and provider-credential exfiltration via unvalidated request-body routing parameters

MEDIUM Published 2026-09-30 Modified 2026-09-30 Official page ↗
Aliases
CVE-2026-84377
Ecosystem
PyPI
Packages
litellm
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-918
Reviewed
2026-09-30

Affected packages

• PyPI litellm: < 1.88.6 → fixed in 1.88.6 • PyPI litellm: >= 1.89.0, < 1.89.7 → fixed in 1.89.7 • PyPI litellm: >= 1.90.0, < 1.90.7 → fixed in 1.90.7 • PyPI litellm: >= 1.91.0, < 1.91.5 → fixed in 1.91.5 • PyPI litellm: >= 1.92.0, < 1.92.2 → fixed in 1.92.2 • PyPI litellm: >= 1.93.0, < 1.93.2 → fixed in 1.93.2 • PyPI litellm: >= 1.94.0, < 1.94.3 → fixed in 1.94.3 • PyPI litellm: >= 1.95.0, < 1.95.1 → fixed in 1.95.1 • PyPI litellm: >= 1.96.0, < 1.96.2 → fixed in 1.96.2

Description

Impact Any authenticated LiteLLM proxy user could redirect an outbound provider call to a destination they control and cause the proxy to send its own configured provider credentials to that destination. The proxy's request-body validation was a denylist that did not cover every sensitive parameter and did not inspect parameters nested inside other request fields, so a caller could supply a routing or credential value that the proxy applied without clearing the operator's stored key. Any authenticated user could therefore exfiltrate the operator's upstream provider credentials and other configured secrets, and perform Server-Side Request Forgery against internal services reachable from the proxy. Patches Fixed in 1.96.2, 1.95.1, 1.94.3, 1.93.2, 1.92.2, 1.91.5, 1.90.7, 1.89.7, and 1.88.6. Workarounds Set `general_settings.allow_client_side_credentials` to `false` so callers cannot override connection parameters, restrict proxy keys to trusted callers, and block the affected parameters (`api_base`, `base_url`, `model_list`, `fallbacks`, provider credential fields) at a reverse proxy or API gateway.

Related

Alias · CVE (1)

  • CVE-2026-84377 LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References