GitHub Advisoryadvisory · Packagist
GHSA-3cvm-7wrh-qrf9 Craft CMS vulnerable to stored Cross-site Scripting via /admin/settings/fields page
MEDIUM
Official page ↗
- Aliases
- CVE-2022-37247
- Ecosystem
- Packagist
- Packages
- craftcms/cms
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-09-23
Affected packages
• Packagist craftcms/cms: >= 4.0.0-RC1, < 4.2.1 → fixed in 4.2.1
Description
Craft CMS 4.2.0.1 is vulnerable to stored a cross-site scripting (XSS) via /admin/settings/fields page.
Related
Alias · CVE (1)
- CVE-2022-37247 Craft CMS 4.2.0.1 is vulnerable to stored a cross-site scripting (XSS) via /admin/settings/fields page. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-37247 advisory
- https://github.com/craftcms/cms/commit/cedeba0609e4b173cd584dae7f33c5f713f19627 web
- https://github.com/craftcms/cms package
- https://github.com/craftcms/cms/blob/3.7.55.2/src/helpers/Cp.php web
- https://github.com/craftcms/cms/blob/4.0.0-RC1/src/helpers/Cp.php web
- https://labs.integrity.pt/advisories/cve-2022-37247 web