GitHub Advisoryadvisory · PyPI

GHSA-3f48-9j7q-q2gv NI MeasurementLink Python Services Improper Access Restriction vulnerability

HIGH Published 2023-10-05 Modified 2023-10-05 Official page ↗
Aliases
CVE-2023-4570
Ecosystem
PyPI
Packages
ni-measurementlink-service
Severity
High
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-420
Reviewed
2023-10-05

Affected packages

• PyPI ni-measurementlink-service: < 1.1.1 → fixed in 1.1.1 • PyPI ni-measurementlink-service: >= 1.2.0.dev0, < 1.2.0 → fixed in 1.2.0

Description

Impact An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the `ni-measurementlink-service` Python package and all previous versions. Patches Upgrade all Python measurement plug-ins to use `ni-measurementlink-service` version 1.1.1 or later. References Visit ni.com/info and enter the info code `cve-2023-4570` for more information.

Related

Alias · CVE (1)

  • CVE-2023-4570 An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services… vulnerability

Weakness · CWE (1)

  • CWE-420 Unprotected Alternate Channel weakness

References