GitHub Advisoryadvisory · npm
GHSA-3f5f-xgrj-97pf Parse Server is vulnerable to Server-Side Request Forgery (SSRF) via Instagram OAuth Adapter
HIGH
Official page ↗
- Aliases
- CVE-2025-68150
- Ecosystem
- npm
- Packages
- parse-server
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
- Weaknesses
- CWE-918
- Reviewed
- 2025-12-16
Affected packages
• npm parse-server: >= 9.0.0, < 9.1.1-alpha.1 → fixed in 9.1.1-alpha.1
• npm parse-server: < 8.6.2 → fixed in 8.6.2
Description
Impact
The Instagram authentication adapter allows clients to specify a custom API URL via the `apiURL` parameter in `authData`. This enables SSRF attacks and possibly authentication bypass if malicious endpoints return fake responses to validate unauthorized users.
Patches
Fixed by hardcoding the Instagram Graph API URL `https://graph.instagram.com` and ignoring client-provided `apiURL` values.
Workarounds
None.
Related
Alias · CVE (1)
- CVE-2025-68150 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-3f5f-xgrj-97pf web
- https://nvd.nist.gov/vuln/detail/CVE-2025-68150 advisory
- https://github.com/parse-community/parse-server/pull/9988 web
- https://github.com/parse-community/parse-server/pull/9989 web
- https://github.com/parse-community/parse-server package