GitHub Advisoryadvisory · npm
GHSA-3f95-r44v-8mrg Command injection in simple-git
HIGH
Official page ↗
- Aliases
- CVE-2022-24433
- Ecosystem
- npm
- Packages
- simple-git
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-77
- Reviewed
- 2022-03-14
Affected packages
• npm simple-git: < 3.3.0 → fixed in 3.3.0
Description
The package simple-git before 3.3.0 is vulnerable to Command Injection via argument injection. When calling the .fetch(remote, branch, handlerFn) function, both the remote and branch parameters are passed to the git fetch subcommand. By injecting some git options, it was possible to get arbitrary command execution.
Related
Alias · CVE (1)
- CVE-2022-24433 The package simple-git before 3.3.0 are vulnerable to Command Injection via argument injection. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-24433 advisory
- https://github.com/steveukx/git-js/pull/767 web
- https://github.com/steveukx/git-js package
- https://github.com/steveukx/git-js/releases/tag/simple-git%403.3.0 web
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2421245 web
- https://snyk.io/vuln/SNYK-JS-SIMPLEGIT-2421199 web