GitHub Advisoryadvisory · Packagist

GHSA-3fj4-q72x-x2g9 ADOdb Library SQL Injection

CRITICAL Published 2022-05-17 Modified 2023-07-31 Official page ↗
Aliases
CVE-2016-7405
Ecosystem
Packagist
Packages
adodb/adodb-php
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2023-07-31

Affected packages

• Packagist adodb/adodb-php: >= 5.0, < 5.20.7 → fixed in 5.20.7

Description

The `qstr` method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Related

Alias · CVE (1)

  • CVE-2016-7405 The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References